Installing Software

Installation Instructions Included in this Guide include

Windows

Adobe Reader

  1. Go to ► https://get.adobe.com/reader/
  2. Uncheck ►any optional offers on the Adobe website.
  3. Select ► Install Now (bottom right corner).
  4. Select ► Save or Run.
  5. Select ► the downloaded file icon to run it.   

Note: Once you Select on the file it will install. If it asks for permission, Select Yes.

Google Chrome

  1. Go to ► https://www.google.com/chrome/browser/desktop/index.html
  2. Select ► Download Chrome. Google will automatically choose your operating system.
  3. Select ► Accept and Install to download.
  4. Select ► Save or Run or Select on the downloaded file icon to run the program. 

Note: Once you Select on the file it will install.  If it asks for permission, Select Yes.Chrome will install and open. 

Firefox Quantum 

  1. Go to ► https://www.mozilla.org/en-US/firefox/
    • Your download will begin automatically.  
  2. Select ► the downloaded file. 
    • If it asks to Run or Save, select Yes
  3. Select ► Yes if your computer asks to install.

Note: Firefox will open. If it asks to import bookmarks, you can do so if you wish. 

Java

  1. Go to ► https://java.com/download
  2. Select ► the red Java Download button. 
  3. Select ► Agree and Start Free Download once asked to agree to Terms and Conditions.
  4. Run ► the file from where it was saved
  5. Select ► Yes when asked for permission to install the software
  6. Select ► Install on the Installation Wizard.This will begin to install Java. 

Box Edit

  1. Go to ►​​​​ https://www.box.com/
  2. Log in ► using your credentials (Make sure you include @isu.edu after your username)
  3. Select ► your account in the top right, which may be your initials.
  4. Select ► Apps on the popup menu.
  5. Select ► Box Edit and then Learn more.
  6. Select ► Add on the left hand side. 
  7. Open ► a document through Box; any Word document should work.
  8. Select ► the Open icon in the top right.
  9. Select ► Download in the Install Box Tools menu.
  10. Select ► the downloaded file and run it.
  11. Select ► Continue on the window that pops up in Box once the program is installed.

Note: This will open up your selected file in Word or any other Microsoft Office product that you choose. When  you save changes in the document, those will be saved back to Box.com

Box for Office

Note:  You must already have Microsoft Office installed

  1. Go to ► https://www.box.com/
  2. Log in ► using your credentials (Make sure you include @isu.edu after your username)
  3. Select ► your account in the top right, which may be your initials.
  4. Select ► Apps on the popup menu.
  5. Select ► Box Edit and then Learn more.
  6. Select ► Add on the left hand side. 
  7. This will initialize the download. This file will appear wherever your downloads normally appear. If it asks to Save or Run please do so, or Select the file itself if you do not have those options.
  8. Select ► Install on the new window that opens.
  9. Select ►​​​​​​​ Yes when asked for permission to install.
  10. Select ► Finish once the install is completed.

VLC Media Player

  1. Go to ► https://www.videolan.org/vlc/index.html
  2. Select Download VLC. VLC will automatically recognize your operating system
  3. Select on the downloaded file. If your browser asks you to Run or Save, please do so.
  4. VLC will ask for you for permission to install. Select Yes.
  5. Once this is finished your installation of VLC is ready to be used.

Shockwave Flash Player

  1. Go to ► https://get.adobe.com/shockwave/
  2. Select ► the yellow Download Now button in the bottom right.
  3. Select ► Save.
  4. Run ► the file from your browser by selecting the file.
  5. Select ► Install in the Shockwave Installer.

7-Zip

  1. Go to ► www.7-zip.org.
  2. Select ► the download version that matches your computer. (If you are not sure, go here: https://support.microsoft.com/en-us/help/13443/windows-which-operating-system.)
  3. Run ► the file from where it was downloaded.
  4. Select ►​​​​​​​ Install.
  5. Close ► the window once installed.

Mac OS X

Adobe Reader

  1. Go to ► https://get.adobe.com/reader/
  2. Uncheck ► any optional offers.
  3. Select ► Download now in the bottom right corner of the page.
  4. Run ► the file from the downloads folder. This will open another folder, which contains the actual installation file.
  5. Run ► this file. This will run you through the installation, and once it is finished you will be able to start using Adobe Reader. 

Google Chrome

  1. Go to ► https://www.google.com/chrome/browser/desktop/index.html
  2. Select ►​​​​​​​ Download Chrome. Google will automatically choose your operating system.
  3. Select ►​​​​​​​ Accept and Install to continue to download.
  4. Run ► the file from the Downloads folder or wherever it was saved. Once you run this file, Google will pop up in a new window alongside a folder.
  5. Drag ► Google Chrome into this folder. This will copy Google Chrome into your applications folder.
  6. Select ► the folder icon and you will be able to find Google Chrome inside it. 

Firefox Quantum

  1. Go to ► https://www.mozilla.org/en-US/firefox/
  2. Select ►​​​​​​​ Download now.
  3. Run ► the file from where it was saved.
  4. Select ► the file and it will open a window that displays Firefox next to the Applications folder.
  5. Drag ►​​​​​​​ Firefox into the Applications folder.
  6. Run ►​​​​​​​ Firefox from the Applications folder.

Java

  1. Go to ► https://java.com/download
  2. Select ► the red Java Download button.The website will then redirect you, and ask you to agree to the Terms and Conditions and ask that you download.
  3. Select  ►​​​​​​​ Agree and Start Free Download.
  4. Run ► the file from where it was saved.
  5. Select ► the file and it will open a window that displays Java.
  6. Select ► this icon and open it. This may ask for your Mac password.
  7. Select ►​​​​​​​ Next. This will install Java.

Note: Java is now finished, and will work with your applications. 

Box Edit

Must already have Microsoft Office installed

  1. Go to ► https://www.box.com/
  2. Log in ► using your credentials (Make sure you include @isu.edu after your username) 
  3. Select ► your account in the top right, which may be your initials.
  4. Select ►​​​​​​​ Apps in the popup menu.
  5. Select ► Box Edit 
  6. Select ► Learn more.
  7. Select ►​​​​​​​ Add on the left hand side. 
  8. Open ► a document through Box; any Word document should work.
  9. Select ►​​​​​​​ Download from the Install Box Tools menu.
  10. Select ► the downloaded file and run it.
  11. Select ► Continue on the window that pops up in Box once the program is installed.

Note: This will open up your selected file in Word or any other Microsoft Office product that you chose. Any changes you make in this document will be saved back to Box.com

VLC Media Player

  1. Go to ► https://www.videolan.org/vlc/index.html
  2. Select ► Download VLC.  VLC will automatically recognize your Operating System
  3. Run ► the file from where it was saved.
  4. Select ► the file and it will open a window that displays VLC next to the Applications folder.
  5. Drag ► VLC into the Applications folder.
  6. Run ►​​​​​​​ VLC from the Applications folder.

Shockwave Flash Player

  1. Go to ► https://get.adobe.com/shockwave/
  2. Select ► Macintosh OSX on the Step 1 drop-down menu.
  3. Select ► Shockwave (OS X 10.6 and above) on the Step 2 drop-down menu.
  4. Select ►​​​​​​​ Download now in the bottom right
  5. Run ► the file from where it was downloaded. This will open another folder containing Shockwave_Installer_Full.pkg
  6. Select ► this file. Another menu will open.
  7. Select ► Continue until it asks you to Agree or Disagree.
  8. Select ►​​​​​​​ Agree and then Install. This may ask for your password. 
  9. Close ► the window once installation is complete.


 


 

Details

Article ID: 43405
Created
Thu 11/30/17 6:55 PM
Modified
Wed 1/20/21 10:24 AM