Issue / Question
VPN access is required to access Idaho State University network resources from home or other off-campus locations.
Environment
-
Platform
-
Audience Affected
Cause
Some campus services are unavailable when connecting from outside networks.
Resolution
How to Request VPN Access
Please click
VPN Request to request access. You will need to receive e-mail confirmation that access has been granted before you can install the software.
Determining Windows Version (32-bit or 64-bit)
-
Select Settings (gear icon)
-
Select System
-
Find About link (left)
Installation Instructions
-
-
Type ISU Username
-
Type ISU Password
-
Select Download Windows 64-bit GlobalProtect agent or Download Windows 32-bit GlobalProtect agent, depending on which Windows version you are using
-
Find the GlobalProtect installation package in the downloads
-
Open GlobalProtect installation package
-
Select Next when the installation screen appears
-
Select Next on Select Installation Folder
-
Select Next on Confirm Installation
-
Wait for the installation to complete
-
Select Close when installation is complete
-
Type bengalgateway.isu.edu for the portal address
-
Type BengalWeb User ID and Password
-
Select Yes on User Account Control
Disconnecting the VPN
Note: Always disconnect from the VPN when not using it to do work for Idaho State University.
-
Right-click the GlobalProtect VPN icon
-
Select Disconnect
ITS STAFF ONLY
Please get in touch with the IT Service Desk for additional assistance.
(208) 282-4357 or Go to
chat